Postavi Compiz pitanje !

Compiz Fusion, Awn, Screenlets, itd...

Postavi Compiz pitanje !

PostPostao/la faragos » 22 sij 2009, 20:35

Postovani
Ova tema je zamisljena da postavite pitanja u vezi samog setupa compiza ili informacije o samom projektu
Pitanja tipa : Kako da omogucim kocku, sto je reflection ili scale plugin, sto je compiz i sl.
Za ostale stvari molim otvorite poseban topic !



Pozz svima, zanima me dali se može inst.beryl na Ubuntu 8.10 intrepid . Ako se može kako i gdje da skinem.
Htjeo bih isprobati tu 3d kocku na mome laptopu.
Hvala.
Zadnja izmjena: Hmmmm; 10 vel 2009, 20:06; ukupno mijenjano 1 put/a.
Faragos
Avatar
faragos
Sr. Member
Sr. Member
 
Postovi: 407
Pridružen/a: 24 pro 2008, 14:27
Lokacija: Osijek

Odg: Ubuntu beryl

PostPostao/la sale » 22 sij 2009, 20:39

faragos je napisao/la:Pozz svima, zanima me dali se može inst.beryl na Ubuntu 8.10 intrepid . Ako se može kako i gdje da skinem.
Htjeo bih isprobati tu 3d kocku na mome laptopu.
Hvala.


Zaboravi Beryl. On ti je stari projekt koji je udružen s projektom Compiz Extras, te danas čini CompizFusion. Uostalom, Hmmm je nedavno na forum stavio zanimljiv link ;)

Ako želiš kocku, instaliraj sljedeći paket:

sudo apt-get install compizconfig-settings-manager


Nakon toga se prošeći izbornikom: Sustav > Postavke > CompizConfig Settings Manager > i aktiviraj Desktop Cube
Zadnja izmjena: sale; 22 sij 2009, 20:41; ukupno mijenjano 1 put/a.
Artificial intelligence is no match for natural stupidity
slika
Avatar
sale
Administrator
Administrator
 
Postovi: 968
Pridružen/a: 18 svi 2007, 18:25
OS: Ubuntu (najnoviji, Unity)

Odg: Ubuntu beryl

PostPostao/la faragos » 22 sij 2009, 20:46

Hvala sale  ;) :D ;D
Zadnja izmjena: faragos; 22 stu 2009, 15:04; ukupno mijenjano 1 put/a.
Faragos
Avatar
faragos
Sr. Member
Sr. Member
 
Postovi: 407
Pridružen/a: 24 pro 2008, 14:27
Lokacija: Osijek

Odg: Ubuntu beryl

PostPostao/la sale » 22 sij 2009, 21:03

faragos je napisao/la:Hvala sale ,de mi reci taj compiz si mogu instalirati ili? mislim možda je malo glupavo pitanje ali jbga ja sam ti nov u linuxu.


U Intrepidu je po defaultu instaliran. Efekte možeš uključiti tako da odeš u Sustav > Postavke > Izgled > Vizualni efekti (stavi na Extra).
Prije nego što se javi amd64 ( :P ), postoji i kraći put do te opcije: desni klik miša na radnoj površini > Promjena pozadine radne površine > Vizualni efekti.
Artificial intelligence is no match for natural stupidity
slika
Avatar
sale
Administrator
Administrator
 
Postovi: 968
Pridružen/a: 18 svi 2007, 18:25
OS: Ubuntu (najnoviji, Unity)

Odg: Ubuntu beryl

PostPostao/la faragos » 22 sij 2009, 23:10

Hvala na uputstvima uspio sam instalirati compiz .Skužio sam kako se aktivira ona fora sa vatrom i vodom ali kocku da sastavim brate mili ne kontam.
Faragos
Avatar
faragos
Sr. Member
Sr. Member
 
Postovi: 407
Pridružen/a: 24 pro 2008, 14:27
Lokacija: Osijek

Odg: Ubuntu beryl

PostPostao/la Hmmmm » 22 sij 2009, 23:18

ccsm > general options > Desktop size

Stavi Horizontal Virtual size na 4, ostalo na 1

Isto tako enejblaj u ccsm-u rotate cube i desktop cube pluginove.
Da
Avatar
Hmmmm
Administrator
Administrator
 
Postovi: 515
Pridružen/a: 17 vel 2007, 11:24

Odg: Ubuntu beryl

PostPostao/la franko » 23 sij 2009, 16:20

Ma radi to odlično i s manje ili više od 4 radne površine. Ja npr. imam 3 radne površine, 4 mi za sada ne trebaju. Samo onda, naravno, tehnički gledano to više nije kocka, ali efekt je isti. :-)
Omnia sunt communia.
Avatar
franko
Hero Member
Hero Member
 
Postovi: 1289
Pridružen/a: 16 stu 2006, 13:12
Lokacija: Umag

Odg: Ubuntu beryl

PostPostao/la faragos » 25 sij 2009, 21:51

Hvala na uputstvima.  ;)
Faragos
Avatar
faragos
Sr. Member
Sr. Member
 
Postovi: 407
Pridružen/a: 24 pro 2008, 14:27
Lokacija: Osijek

Odg: Ubuntu beryl

PostPostao/la frula » 10 vel 2009, 19:49

Zašto meni na tim efektima piše:

Desktop effects could not be enabled ???

Cak niti normal nemogu upaliti, kamoli Extra  ???
Avatar
frula
Newbie
Newbie
 
Postovi: 18
Pridružen/a: 28 srp 2008, 10:27
Lokacija: Zagreb

Odg: Ubuntu beryl

PostPostao/la Hmmmm » 10 vel 2009, 19:50

Koja graficka kartica ?
Da
Avatar
Hmmmm
Administrator
Administrator
 
Postovi: 515
Pridružen/a: 17 vel 2007, 11:24

Odg: Postavi Compiz pitanje !

PostPostao/la soco » 11 vel 2009, 15:22

ja sam jucer stavljao Interpid na jedan od svojih kompova gdje su mi je XP i javila mi se ista greska prilikom ukljucivanja efekata pod opcijama izgleda... nisam mogao ukljuciti ni normal ni extra, ali vjerojatno sam uspio zbog restarta kompa i aktivacije ATI drivera nakon same instalacije...

medutim, ja sam instalirao Compiz Manager preko Synoptica i podesio si zeljene postavke efekata i dalje radilo sve bez ikakvih problema...
soco
Jr. Member
Jr. Member
 
Postovi: 85
Pridružen/a: 11 lip 2007, 11:12

Odg: Postavi Compiz pitanje !

PostPostao/la frula » 11 vel 2009, 16:37

@Hmmmm

laptop: Radeonka X1100  8)
Avatar
frula
Newbie
Newbie
 
Postovi: 18
Pridružen/a: 28 srp 2008, 10:27
Lokacija: Zagreb

Odg: Postavi Compiz pitanje !

PostPostao/la franko » 11 vel 2009, 17:06

Trebaš ili instalirati fglrx (vlasnički drajver) ili konfigurirati radeon (slobodni) drajver, ako ti je kartica podržana. I onda ćeš moć pokretat efekte.
Omnia sunt communia.
Avatar
franko
Hero Member
Hero Member
 
Postovi: 1289
Pridružen/a: 16 stu 2006, 13:12
Lokacija: Umag

Odg: Postavi Compiz pitanje !

PostPostao/la frula » 11 vel 2009, 18:08

Kad odem na System --> Administration ---> Hardware Drives ..

Kod ATI Fire GL mi je kvačica, ali Status je --> Not in use  ???

Kako da to konfiguriram  :o
Avatar
frula
Newbie
Newbie
 
Postovi: 18
Pridružen/a: 28 srp 2008, 10:27
Lokacija: Zagreb

Odg: Postavi Compiz pitanje !

PostPostao/la Hmmmm » 11 vel 2009, 18:20

Pejstaj svoj /etc/X11/xorg.conf te
lsmod | grep radeon
Da
Avatar
Hmmmm
Administrator
Administrator
 
Postovi: 515
Pridružen/a: 17 vel 2007, 11:24

Odg: Postavi Compiz pitanje !

PostPostao/la frula » 11 vel 2009, 19:40

Kod: Označi sve
# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "InputDevice"
   Identifier   "Generic Keyboard"
   Driver      "kbd"
   Option      "XkbRules"   "xorg"
   Option      "XkbModel"   "pc105"
   Option      "XkbLayout"   "hr"
EndSection

Section "InputDevice"
   Identifier   "Configured Mouse"
   Driver      "mouse"
   Option      "CorePointer"
EndSection

Section "InputDevice"
   Identifier   "Synaptics Touchpad"
   Driver      "synaptics"
   Option      "SendCoreEvents"   "true"
   Option      "Device"      "/dev/psaux"
   Option      "Protocol"      "auto-dev"
   Option      "HorizEdgeScroll"   "0"
EndSection

Section "Device"
   Identifier   "Configured Video Device"
EndSection

Section "Monitor"
   Identifier   "Configured Monitor"
EndSection

Section "Screen"
   Identifier   "Default Screen"
   Monitor      "Configured Monitor"
   Device      "Configured Video Device"
EndSection

Section "ServerLayout"
   Identifier   "Default Layout"
   Screen      "Default Screen"
   InputDevice   "Synaptics Touchpad"
EndSection
Zadnja izmjena: sale; 11 vel 2009, 19:57; ukupno mijenjano 1 put/a.
Avatar
frula
Newbie
Newbie
 
Postovi: 18
Pridružen/a: 28 srp 2008, 10:27
Lokacija: Zagreb

Odg: Postavi Compiz pitanje !

PostPostao/la franko » 11 vel 2009, 22:48

frula je napisao/la:Kad odem na System --> Administration ---> Hardware Drives ..

Kod ATI Fire GL mi je kvačica, ali Status je --> Not in use  ???

Kako da to konfiguriram  :o


Dole desno, odmah iznad gumba Close, imaš gumb Activate. Klikaj na njega, pusti Ubuntu da učini sve što treba i onda restartaj komp.
Omnia sunt communia.
Avatar
franko
Hero Member
Hero Member
 
Postovi: 1289
Pridružen/a: 16 stu 2006, 13:12
Lokacija: Umag

Odg: Postavi Compiz pitanje !

PostPostao/la frula » 12 vel 2009, 08:47

Nemam te kvacice :D

Driver mi je Enabled (postavljena kvacica) ali pise: Not in use  ???

Da li mogu negdje naci driver za linux ili nesto slicno da mi prepozna FireGL  ???
Avatar
frula
Newbie
Newbie
 
Postovi: 18
Pridružen/a: 28 srp 2008, 10:27
Lokacija: Zagreb

Odg: Postavi Compiz pitanje !

PostPostao/la Hmmmm » 12 vel 2009, 14:24

Kao sto pitah u proslom postu.

lsmod | grep radeon

A moze i :
glxinfo | grep -i renderin
Da
Avatar
Hmmmm
Administrator
Administrator
 
Postovi: 515
Pridružen/a: 17 vel 2007, 11:24

Odg: Postavi Compiz pitanje !

PostPostao/la franko » 12 vel 2009, 15:35

Ma koju ti verziju Ubuntu uopće imaš? Gnome, KDE ili nešto treće? Očito je da ti Hardware Drivers prozor izgleda prilično drugačije nego u standardnom (Gnome) Intrepidu...

I daj ovo što Hmmmm kaže.
Omnia sunt communia.
Avatar
franko
Hero Member
Hero Member
 
Postovi: 1289
Pridružen/a: 16 stu 2006, 13:12
Lokacija: Umag

Odg: Postavi Compiz pitanje !

PostPostao/la sehrz » 23 vel 2009, 15:00

hej kolege
moze pitanje kaj bi trebal napravit tj.konfigurirat da mi kocka bude kao prozirna (kao da se vidi druga strana) !?
hvala!
sehrz
Newbie
Newbie
 
Postovi: 37
Pridružen/a: 04 vel 2009, 13:32

Odg: Postavi Compiz pitanje !

PostPostao/la antisa » 23 vel 2009, 15:13

Sustav > Postavke > Advanc. Desktop Effects Settings > Desktop Cube > Transparent Cube kartica.
Avatar
antisa
Hero Member
Hero Member
 
Postovi: 708
Pridružen/a: 16 ožu 2008, 16:24
Lokacija: Split
OS: 13.04

Odg: Postavi Compiz pitanje !

PostPostao/la franjo101 » 03 ožu 2009, 12:04

Dobar dan svima!
Pitanje će možda izgledat malo smušeno, al sam novi i molim da se to uzme u obzir. :-)
Znate onaj balončić s objašnjenjem koji se pojavi kad zadrižiš miša nad nečim (recimo gumbom za minimizaranje prozora)? E, za taj balončić postoje animacije, koje sam (nekako) imao naštelane na "random". Nakon štelanja drugih opcija nekako sam uspio isključiti tu "random" opciju i sada se balončić pojavljuje uz samo jedan efekt. Da li itko zna kako poštelat tu opciju?
Hvala dobroj duši unaprijed.
Avatar
franjo101
Newbie
Newbie
 
Postovi: 18
Pridružen/a: 03 ožu 2009, 11:51

Odg: Postavi Compiz pitanje !

PostPostao/la sale » 03 ožu 2009, 12:31

franjo101 je napisao/la:Dobar dan svima!
Pitanje će možda izgledat malo smušeno, al sam novi i molim da se to uzme u obzir. :-)
Znate onaj balončić s objašnjenjem koji se pojavi kad zadrižiš miša nad nečim (recimo gumbom za minimizaranje prozora)? E, za taj balončić postoje animacije, koje sam (nekako) imao naštelane na "random". Nakon štelanja drugih opcija nekako sam uspio isključiti tu "random" opciju i sada se balončić pojavljuje uz samo jedan efekt. Da li itko zna kako poštelat tu opciju?
Hvala dobroj duši unaprijed.


To ti se zove Tooltip ;)
Efekte možeš podesiti pomoću CompizConfig settings managera (imaš ga u repozitoriju). Pogledaj pod Animations > kartica open animation. Ovdje ti se podešavaju sve opcije oko efekata kod otvaranja prozora, tooltipa itd. Recimo, ja sam si postavio pod "Open effect" Zoom za sve prozore, uključujući i tooltip. U window match polju (kad stvaraš novi efekt ili uređuješ postojeći) upisao sam sljedeće:

Kod: Označi sve
((type=Normal | Unknown | Tooltip) | name=sun-awt-X11-XFramePeer | name=sun-awt-X11-XDialogPeer) & !(role=toolTipTip | role=qtooltip_label) & !(type=Normal & override_redirect=1) & !(name=gnome-screensaver)
Artificial intelligence is no match for natural stupidity
slika
Avatar
sale
Administrator
Administrator
 
Postovi: 968
Pridružen/a: 18 svi 2007, 18:25
OS: Ubuntu (najnoviji, Unity)

Odg: Postavi Compiz pitanje !

PostPostao/la franjo101 » 03 ožu 2009, 13:33

SVAKA ČAST!!
Evo naštelo sam i sad sam napokon miran i sretan. Bed je to kad nekaj napipaš na sreću i onda ne znaš di si to štelal.
Ak nije bed, imam pitanje i o temama. Di se one štelaju i kak? Znam da ih se da skinut na Gnome-Look.org.
Avatar
franjo101
Newbie
Newbie
 
Postovi: 18
Pridružen/a: 03 ožu 2009, 11:51

Sljedeća

Natrag na Compiz i pripadajuće aplikacije

Na mreži

Trenutno korisnika/ca: / i 1 gost.